Wednesday, January 30, 2019

A few new one-liners

I like to automate and/or simplify* a lot of processes that I run on my stuff here are a few I am posting for the sake of having them somewhere

FreeBSD Updates

cd /usr/ports/ ; df -hl ; pkg update ; pkg clean -y ; portsclean -C -D -DD -L -P -PP ; df -hl ; portsnap fetch update ; pkg version -vIL= | awk '{print $1}' | sed 's/-[0-9].*//g' | awk '{printf "%s"" ",$0}' | sed 's/^/portmaster -P -y --no-confirm -D /g' | sh ; pkg version -vIL= ; pkg audit -F ; df -hl

Requires portmaster and portupgrade to be installed and prefers ports over pkg - what can I say I hate myself

CentOS Updates

clear; yum clean all; rm -rf /var/cache/yum; yum -y upgrade --skip-broken; package-cleanup --problems; package-cleanup --dupes; rpm -Va --nofiles --nodigest;
I think this requires yum-utils be installed to do the cleaning bits

Debian Updates (also obviously works on Ubuntu)

clear; apt-get update ; apt-get upgrade ; apt-get dist-upgrade; apt-get autoclean;  apt-get autoremove
OpenBSD Updates

I cheat and use openup, a currently free service provided by mtier - more information can be find by going to https://www.mtier.org/solutions/apps/openup/


* so yeah that FreeBSD one isn't "simple" but it does a bunch of stuff I need it to do.

Feel free to use these or whatever, I don't really care.

I don't have a clue

I'm so very tired. It's almost all the time now.